Pulsacoil 2000 - Help needed....

View previous topic View next topic Go down

Pulsacoil 2000 - Help needed....

Post  amc77 on Sun Jun 17, 2012 5:50 pm

I have a 2000 and there is an intermittent problem.

I cant see the problem on any of these posts so here goes..

Both thermostats, pump were replaced due to leaking and pump causing system to trip.

Everything seemed fine then suddenly there is no hot water. the water is being heated but the pump was not working. this problem would come and go, sometimes it would not work for hours then it would be fine. there was no pattern.

I was advised it was a sensor fault so i had both replaced. the problem is still there.

I dont want to have the pcb replaced to find out it is something else so does anyone know if this could be the case? i.e would a pcb cause this intermittent problem or would it be either working or not?

The system is working perfect at the moment but im just anticipating the next time it stops working (at least 3-4 times a week for long periods)

So will having a pcb sort this? also - i have noticed a buzzing coming out of the unit when it is not working.

Mnay Thanks

amc77

Posts : 3
Join date : 2012-06-17

View user profile

Back to top Go down

Re: Pulsacoil 2000 - Help needed....

Post  amc77 on Mon Jun 18, 2012 11:15 am

Got in from work, led flashing like a goodun and buzzing noise coming from pump with no hot water.....

Should be back to 2 flashes per seconds later with the pump kicking in when i turn the tap on and everything working fine..If im lucky of course otherwise we will be going without a shower again.....

PCB?

amc77

Posts : 3
Join date : 2012-06-17

View user profile

Back to top Go down

Re: Pulsacoil 2000 - Help needed....

Post  amc77 on Sat Jul 07, 2012 1:09 am

PCB Seemed to have done the job

I would like to take this opportunity to thank everyone for their helpful comments, i would have never been able to do it without them!!

amc77

Posts : 3
Join date : 2012-06-17

View user profile

Back to top Go down

Confirm pump is right

Post  sunny.sahdev on Fri Sep 20, 2013 2:22 am

I am glad you resolved your problem. Regarding the parts you have change, I would like to remind everyone who reads this post that the immersion elements should be shel incoloy ones, the thermostats should reach 73oC and the pump should be a Grundfos 15-50X18

sunny.sahdev

Posts : 383
Join date : 2013-08-21
Age : 31
Location : Vedhas Limited, 960 Capability Green

View user profile http://www.vedhas.co.uk/vedhas-what-we-do/pulsacoil-repair/#

Back to top Go down

Re: Pulsacoil 2000 - Help needed....

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum