Boilermate 2000 no HW or CW Primary return pump not working ?

View previous topic View next topic Go down

Boilermate 2000 no HW or CW Primary return pump not working ?

Post  mark wiffen on Mon Sep 24, 2012 2:54 pm

Hi.....Yesterday as it was cold I decided to turn up my thermostat for the first time this year and got no hot water to the radiators, at this time the hot water also stopped working ! (It had been working fine before this) I am running the Boilermate 2000 with the Ideal Classic... I called an engineer at £89 an hour + VAT...He told me the problem was the Thermostat control knob on the Ideal Classic and possibly the return pump on the boilermate but could not be sure until the thermostat switch was changed... I have since put a new switch on the Ideal classic and checked the return pump by rewiring it from the HW primary pump (the return pump works fine when wired this way)... The Ideal classic is working fine and sending hot water up as far as the primary flow pipe into the Boilermate 2000... Can anyone help with this. Thanks Mark.

mark wiffen

Posts : 5
Join date : 2012-09-24

View user profile

Back to top Go down

Re: Boilermate 2000 no HW or CW Primary return pump not working ?

Post  mike on Tue Sep 25, 2012 4:50 am

Check the ACB
Mike
MGC/H2O

mike

Posts : 1647
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

Re: Boilermate 2000 no HW or CW Primary return pump not working ?

Post  mark wiffen on Tue Sep 25, 2012 6:31 am

mike wrote:Check the ACB
Mike
MGC/H2O

Hi Mike.
Thanks for your response. Is there a way of testing the ACB ?, I have 3 green lights on the ACB, Should I look for burn marks on the back ?. Both backup systems on the Boilermate are working fine. Thanks Mark

mark wiffen

Posts : 5
Join date : 2012-09-24

View user profile

Back to top Go down

Re: Boilermate 2000 no HW or CW Primary return pump not working ?

Post  mike on Tue Sep 25, 2012 6:52 am

Read the book!
Are the red bars on the ACB lit up?
Need to check the fault codes etc.
Matter of going through the unit.
Check supplies at pumps, are the running when they should or when they should not.Is the unit full?
Have you gone through all the post in the BM 200 section on this site?
All has been covered many times before
Mike

mike

Posts : 1647
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

Re: Boilermate 2000 no HW or CW Primary return pump not working ?

Post  mark wiffen on Tue Sep 25, 2012 8:39 am

Hi Mike.
Sorry about the questions, I am a home user with no experience of boilers and little money to throw at this....
When you say read the book I guess you mean the instruction/service guide ?
I have read through many of the other posts much of which had nothing to do with the problem I have.
As I said before I have 3 green lights, there is another upper display LED that has nothing on it, is this where there should be a red bar or line ?
The unit has a mains water supply and no header tank.
With the switch in position 1 the domestic hot water primary pump runs, the boiler downstairs is working fine and sends water up as far as the boilermate primary flow pipe from boiler.
How do I check for fault codes and where will they come up ?
Sorry again.
Thanks.
Mark.

mark wiffen

Posts : 5
Join date : 2012-09-24

View user profile

Back to top Go down

Re: Boilermate 2000 no HW or CW Primary return pump not working ?

Post  mike on Tue Sep 25, 2012 8:55 am

If you have no red bars.
Then sorry the Main ACB (PCB) has failed.
Try;
http://www.segel.co.uk/index.php?main_page=product_info&cPath=19_62_74&products_id=524

Handle with care though.
PCB's do not like static.
I wear gloves for that purpose
Also there is No one who will accept a PCB back once opened!
Also are the 2 pipes coming out of the top of the unit?
Mike
MGC/H2O
Norfolk

mike

Posts : 1647
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

Re: Boilermate 2000 no HW or CW Primary return pump not working ?

Post  mark wiffen on Tue Sep 25, 2012 9:10 am

Hi Mike.
Thanks for your patience and swift reply.
Thanks also for the product link.
There are 2 pipes coming out the top.
Regards.
Mark.

mark wiffen

Posts : 5
Join date : 2012-09-24

View user profile

Back to top Go down

Re: Boilermate 2000 no HW or CW Primary return pump not working ?

Post  mike on Tue Sep 25, 2012 9:14 am

Well if there are 2 pipes out of the top.
Then there is a tank.
May be plastic or a round one.
It is called the F& E tank (feed and expansion)
There is a lot more to these units than some people think.
Mike
MGC/H2O
Norfolk

mike

Posts : 1647
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

Re: Boilermate 2000 no HW or CW Primary return pump not working ?

Post  mark wiffen on Tue Sep 25, 2012 11:03 am

Hi Mike.
I will check up in the loft again, maybe I missed it.
Thanks.
Mark.

mark wiffen

Posts : 5
Join date : 2012-09-24

View user profile

Back to top Go down

Re: Boilermate 2000 no HW or CW Primary return pump not working ?

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum