boiler on red then no c/heating

View previous topic View next topic Go down

boiler on red then no c/heating

Post  brian07 on Fri Jan 16, 2009 3:13 am

Trying to understand which is at fault
Potterton Suprema 40 boiler in kitchen or
Gledhill Boilermate 2000 (no ‘switch’) both installed early 2001, gledhill has Sentinel X100 inhibitor protection installed march 2001

Problem
arrive home, house cold, gledhill control set to middle position and ‘fingers’ set to on for central heating at this time....
Boiler panel has red flashing light
I reset boiler, it fires normally and quickly provides hot water
but....despite being in the timer period, the central heating does not start, even if I push the gledhill control to the ‘on’ position

tried turning power off and on to the gledhill, still no c / heating

Heating appears to return if the gledhill control reaches a point where the
‘fingers’ are set to off and will then restart at the next ‘on finger’
(winding the control through 24 hours does not kick start c/h)

question 1 is this the boiler or the gledhill
question 2 how can I immediately restart c/ heating after boiler on flashing red as described above ?? do I reset the gledhill before resetting boiler ??
question 3 read on your site about boiler being set at max, (‘boiler not firing’ query) mine is not set to max, is this important ??
help much appreciated
regards
Brian

brian07

Posts : 2
Join date : 2009-01-16

View user profile

Back to top Go down

Re: boiler on red then no c/heating

Post  Mike the Boilerman on Fri Jan 16, 2009 4:58 am

Hi Brian,

This sounds like possible timer failure, but more likely it is because the thermal store water is not hot enough.

It is critically important to have the gas boiler temp control set to MAX or the water in the thermal store may not ever get up to 65 degrees C. This is particularly likely as you say your boiler is locking out and needing a re-set regularly. The control board will NOT allow the heating to operate unless the store water is at 65 degree C or hotter.

Turning your boiler up to MAX may well sort it out. Do let us know!

Cheers, Mike

Mike the Boilerman
Admin

Posts : 426
Join date : 2009-01-08

View user profile http://gledhill-repairs.forumotion.net

Back to top Go down

Re: boiler on red then no c/heating

Post  brian07 on Fri Jan 30, 2009 5:24 am

Hi Mike
boiler set to max and heating ran perfectly for three days, after 30 mins of heating on, gledhill showed T1=61(degrees) T2=35 and T3=H46; after 5 hours T1=75 T2=37 T3=H37.
But then went back to red flashing on boiler when I arrived at house on day four (not moved there yet so only call once or twice per day) and T1=31, T2=20, T3=H22. Not there long enough to find out when it trips.
What do you think is causing the boiler to trip and are those numbers what you would expect when it is running normally especially the T1=75 after 5 hours, is this too high ??
regards
Brian

brian07

Posts : 2
Join date : 2009-01-16

View user profile

Back to top Go down

Re: boiler on red then no c/heating

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum