Help needed with Pulsacoil 2000

View previous topic View next topic Go down

Help needed with Pulsacoil 2000

Post  eleanordavies on Sun Dec 28, 2014 7:33 am

Hi Mike

You came to South London last year to look at my Pulsacoil 2000 (c. 10 years old) which was regularly showing the red fault light and requiring reset. At the time you changed the thermostat and this seemed to resolve the problem.

Now we have lost our hot water supply - we have confirmed that the black tank is full to the water line, the green light is showing with no red fault light, the red LED on the circuitboard is blinking twice per second and there are no other obvious problems.

When we turn the tap on we can hear a noise from the tank but not from the pump. There seems to be a permanent electrical buzzing noise coming from the circuit board, which changes in volume when we move the (I, II, III) switch on the pump.

Any advice? Or do I need to get someone to come and look at this?

Many thanks

Eleanor

eleanordavies

Posts : 1
Join date : 2014-12-28

View user profile

Back to top Go down

Re: Help needed with Pulsacoil 2000

Post  mike on Sun Dec 28, 2014 4:05 pm

Hi,
I am not the Mike who came to you.
Try bleeding the pump/ check it turns round.
Mike
Norwich

mike

Posts : 1666
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum