Boilermate 2000 - Multiple Issues (pcb gone?)

View previous topic View next topic Go down

Boilermate 2000 - Multiple Issues (pcb gone?)

Post  Taz on Sat Feb 07, 2015 3:50 am

Hi All,

I am a complete novice when it comes to all things electrical/boiler related so please bear with me. I have the following issues with my BM 2000 and would appreciate any advice/support.

1. Constant heat. The head is off from the BM and the thermostat is on its lowest setting yet the central heating is on full blast.

2. Strange gurgling noises coming from either the store or the pipe work. I thought perhaps the store wasn't getting enough water but when I checked the storage tank in the loft its full.

3. A few days ago I had no heating for a short period of time. Boilermate was on, thermostat was clicked on, but the ideal boiler wouldn't fire or ignite. I switched the ideal boiler off and back on and it then began working. I only had this serviced last week and was told its in mint condition (however I do hear it trying to ignite at time and not light for at least 10 - 15 times).

4. Thermostat doesn't seem to maintain temperature. I don't assume this issue is connected to the BM but thought I'd add it anyway.

5. Intermittent issue with hot water running cold. I doubt it's the sensors as both were replaced less than 2 years ago.

The major issue is point 1. I removed the cover and all 3 LCD lights are on, all 3 pumps are hot, the dial reads ON and if I try to press the buttons to read the store temperature nothing happens.

Hence I believe the PCB has gone. Reading other threads it seems as though a reconditioned unit via CET is the way to go and I can even have a go at fitting myself.

Do you all recommend going this route or should I get an engineer to come take a look before assuming the issue is PCB related?

Much Appreciated

Taz

Posts : 4
Join date : 2015-02-07

View user profile

Back to top Go down

Re: Boilermate 2000 - Multiple Issues (pcb gone?)

Post  mike on Sat Feb 07, 2015 5:37 pm

Main board has gone.
BUT
All because you can see water in the top tank means nothing.
You need to put a hose onto the unit and drain some water out.
If the top tank goes down then good.
But the BM 2000 has 2 tanks inside which are linked with quite a few pipes.
If any parts of the BM 2000 become blocked solid. Then it can be game over.
My advice to anyone with a BM 2000 is to check the top tank / water goes into unit.
Next would be to drain enough water to empty the top tank. And part of the unit.
And put a few bottle of sludge remover / cleaner in.
You will need enough for the unit;
BM 2000 125 = 1.25 bottles
BM 2000 150 = 1.50 bottles
BM 2000 180 = 1.80 bottles

The boiler and rads need it to.
As a rule every 10 rads = 1 bottle.
Alway go up when working the amount out, never go down.

After the cleaning has been done week to a month.
The whole lot, Unit, rads & boiler has to be drained, best done hot.
Then on filling put in the same amount of inhibitor / protector as calculated ref the cleaner amount.

Mike

mike

Posts : 1674
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

Re: Boilermate 2000 - Multiple Issues (pcb gone?)

Post  Taz on Mon Feb 09, 2015 3:34 am

Mike,

Thanks a lot! Would the draining be something I could have a go at myself or would need a specialist to do? Please note I'm close to clueless about this stuff.

I do think I could replace the board though. Do u recommend I replace the board then tackle this issue of the draining separately?

Thanks


Taz

Posts : 4
Join date : 2015-02-07

View user profile

Back to top Go down

Re: Boilermate 2000 - Multiple Issues (pcb gone?)

Post  Taz on Wed Feb 11, 2015 1:37 pm

So I managed to replace the acb/pcb. My problem oif constant heating is no more and I see readings for the store temp. Good news right? Wrong. I now have no heating at all. Heating is on. Thermostat is on.

HELP, from anyone appreciated!

Taz

Posts : 4
Join date : 2015-02-07

View user profile

Back to top Go down

Re: Boilermate 2000 - Multiple Issues (pcb gone?)

Post  Taz on Thu Feb 12, 2015 1:16 pm

Short update. Think I have isolated the issue, after a pretty expensive call to Gledhill Technical help. The middle pump (CH) seems to not be functioning correctly. I now get intermittent heating as the pump runs initially then seem to become slower and slower. Ordering a new pump tomorrow.

Taz

Posts : 4
Join date : 2015-02-07

View user profile

Back to top Go down

Re: Boilermate 2000 - Multiple Issues (pcb gone?)

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum