Boilermate 2000 boiler pump stops running

View previous topic View next topic Go down

Boilermate 2000 boiler pump stops running

Post  Hedworx on Thu Sep 03, 2015 12:27 pm

Evening,

I’m having problems with my Boilermate 2000 and Potterton Suprima 60L system. Basically the boiler pump runs for a short time then stops.

I have the following sequence of events:-
BAR 2 – ST and “ON” lit on the LED display along with green LEDs 1 (boiler on) and 2 (boiler pump on); the boiler pump starts/runs and the Potterton boiler fires up. After a while the pump stops running even though the boiler is still lit. The boiler will then stop/cut off. I have a red LED light on the boiler (lockout?) and a green flashing LED. After a short while the red LED goes out and the green LED continues to flash; then the boiler will fire again and the green LED stays on. On the Boilermate ACB everything looks the same (BAR 2 and ON lit plus green LEDs 1 and 2 lit) but the boiler pump is now not running. The boiler will then cut out again and so on…

Is the Boilermate ACB at fault?

Pressing switches SW1 and SW2 shows no error codes and the temperatures displayed look right/reasonable (on 72 - off 75). If I turn the heating on; BAR 1 on the LED display and green LED 3 lights and the corresponding pump runs. Similarly opening a hot tap; BAR 3 will light and the domestic hot water pump will run. When I close the tap this pump continues to run.

Any ideas?

Cheers
Chris

Hedworx

Posts : 4
Join date : 2015-08-11

View user profile

Back to top Go down

Re: Boilermate 2000 boiler pump stops running

Post  mike on Thu Sep 03, 2015 1:53 pm

It does sound like the ACB.
BUT
Check all the connection to the pump and the ACB end.
If terminal connections on the ACB plugs
Remake the pump one.
And next time.
Try switching unit off for a minute or so.Then back on.
Check supply at pump to with a volt meter.
Mike

mike

Posts : 1674
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

Re: Boilermate 2000 boiler pump stops running

Post  Hedworx on Fri Sep 04, 2015 12:46 pm

Thanks Mike for the quick reply.

I've checked all the connections; all are ok.
Tried switching the unit off for a while and then back on (3 times) and the following happened:-
1)  Pump ran for 10mins then stopped and didn't start again.  Voltage was 248-251V.
2)  Pump never started.
3)  Pump ran for 28mins this time before stopping.  Voltage 247-249V.  Red light on Potterton boiler, won't reset.

Upon closer inspection of the ACB it looks like scorch/burn marks next to the black UF5 chip (solid state relay?).  Clearly not a good sign.  (I've tried to attach a photo - can't get this to work).  This maybe a stupid question; but is it possible to replace this chip or will there be other damage to the ACB (can't see anything visually)?  Or do I need to bite the bullet and and fork out ~£250 for a new ACB?

Cheers
Chris

Hedworx

Posts : 4
Join date : 2015-08-11

View user profile

Back to top Go down

Re: Boilermate 2000 boiler pump stops running

Post  mike on Fri Sep 04, 2015 1:00 pm

There is a firm who do recon ones.
But I prefer new ones.
They are different to the old ones.
Mike

mike

Posts : 1674
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

Re: Boilermate 2000 boiler pump stops running

Post  Hedworx on Fri Sep 04, 2015 1:10 pm

Ok so it's defiantly the ACB? No chance to replace the solid state relay? ;-)

Cheers
Chris

Hedworx

Posts : 4
Join date : 2015-08-11

View user profile

Back to top Go down

Re: Boilermate 2000 boiler pump stops running

Post  mike on Fri Sep 04, 2015 1:15 pm

Not much in life is 100%
You are the guy in front of the unit.
Your call, base it on all the info you have etc.
I would say so yes.
Try a recon one.
Or try repairing it.
I have about 50 dead BM 2000 ACB' in my stores!
Try Ebay for one.
Mike

mike

Posts : 1674
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

Re: Boilermate 2000 boiler pump stops running

Post  Hedworx on Fri Sep 04, 2015 1:24 pm

"Not much in life is 100%" - So true; except death and taxes.

Many thanks for your help Mike.

Cheers
Chris

Hedworx

Posts : 4
Join date : 2015-08-11

View user profile

Back to top Go down

Re: Boilermate 2000 boiler pump stops running

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum