Boilermate 2000 Sounds like its about to Explode

View previous topic View next topic Go down

Boilermate 2000 Sounds like its about to Explode

Post  razzandy on Thu Mar 03, 2016 8:35 am

At first our Boilermate started 'occasionally' sounding like thunder but its progressively got worse. It started popping the Limit Thermostat on the main boiler so now we only turn the Ideal Classic Slimline (Main Boiler) on when we need heating or hot water. It must be about 12 years old now and was fitted to a new build. Funny thing is our neighbours boiler is doing exactly the same thing! I am pretty handy with electronics so have done lots of testing.

All pumps are running but the right hand DHW pump runs slow but that's down to a supply of only 53'ish volts. From what I read that is normal. Last June and before this problem I diagnosed and fitted a new ACB (PCB) and this seems to be 'still' operating perfectly fine. All temp senders are not giving any errors but who's to say they are reading correctly? Store temp cuts main boiler in and out at correct range so I cant understand whats causing the thunder sounding boiler 'Nuke'!

Even though the store temp sender is reading fine I have a sneaky suspicion that it may be the store sensor reading the temperature lower than it actually is.

I changed the Limit Thermostat in the Ideal Boiler thinking it was that but no, last night sounded like aliens landing again!!!

Hope you can offer some help Mike or come and fix it for me!?!?! ;-)

Thanks in advance

razzandy

Posts : 4
Join date : 2015-06-03

View user profile

Back to top Go down

Re: Boilermate 2000 Sounds like its about to Explode

Post  mike on Fri Mar 04, 2016 3:48 pm

Well first thing I would do is;
Check the top tank for sludge and for water and the ball valve is ok.
Then I would drain some water out of the unit choice of 2 doc's.
And make sure the unit takes water from the top tank.
If so continue (turn unit off and supply to top tank.
You could drain unit fully.
If really dirty. You could add cleaner via top tank.
When filling the unit place hand over vent and then remove should have air coming out.
If not vent is blocked.
Also your boiler heat exchanger could be at fault hence the noise.
Or the boiler pump although working may have a worn, broken or blocked impellar.
If you think it could be electrical etc.
Try resetting the ACB like when you fitted it.
Lots to try, might hear a few days later after all that!
Mike

mike

Posts : 1646
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum