A-Class on peak boost not working

Go down

A-Class on peak boost not working Empty A-Class on peak boost not working

Post  MatthewM on Sun Dec 01, 2019 2:32 am

Any help much appreciated.
My pulsacoil a-class had a flashing red light in normal operation.
Recently that has stopped. When I push the boost button there is an audible click but not the usual relay noises.
Relay shows no signs of burning.
s2 shows:
70
65
FF
FF
No error in normal operation.
Element reads normal.
Trying to work out where to go next with this please?
Thank you very much

MatthewM

Posts : 8
Join date : 2012-03-26

Back to top Go down

A-Class on peak boost not working Empty Re: A-Class on peak boost not working

Post  Mike the Boilerman on Sun Dec 01, 2019 2:53 am

Firstly, the flashing red light can have different meanings depending on the software version on your PCB. On some, it flashes simply if the store is less than fully hot in order to invite you to press the BOOST button. On others, it means the PCB thinks the BOOST heater element has failed.

Given you found your BOOST element measures correctly (18 Ohms approx), I'm still inclined to focus on the contactor. Is there 240Vac on the input terminals? If not, follow the wires back to the mains supply to find the break.

If you have 240Vac on the contactor input terminals, is there 240Vac on the output terminals when you press the BOOST button? Is there now 20Vac on the heater element terminals? If no, is there 240Vac on the contactor actuator terminals?

These questions should point you in the right direction...


_________________
Mike Bryant AKA Mike the Boilerman, Gledhill repair specialist, webmaster of www.gledhill-repairs.co.uk & www.miketheboilerman.com. For information about my Gledhill repair service or to make a booking call me on 07866 766364. (Please don't phone me for advice if you are fixing a Gledhill yourself, ask on here instead - I run this forum partly to cut down on the phone calls!)

Mike the Boilerman
Admin

Posts : 437
Join date : 2009-01-08

http://gledhill-repairs.forumotion.net

Back to top Go down

A-Class on peak boost not working Empty Re: A-Class on peak boost not working

Post  MatthewM on Sun Dec 01, 2019 3:10 am

Thank you Mike I will crack on and report back. Is it however a suitable test to switch the contractors over as presumably that would give a clear indication?

MatthewM

Posts : 8
Join date : 2012-03-26

Back to top Go down

A-Class on peak boost not working Empty Re: A-Class on peak boost not working

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum