Pump not working

View previous topic View next topic Go down

Pump not working

Post  dollar on Sun Sep 06, 2009 6:16 am

Hi I would appreciate your imput on a fault with my 2000 pump. I still get hot radiators except for my kitchen and conservatory the third pump I checked to see if it was working it doesnt appear to be. Before I get a plumber in is there anything I can do to rectify it myself?. It is a Grunfos UPS 15-50 18, I have however a new UPS 15-50 130 that was left in its new box at my new place can that replace the 15-50 18?

dollar

Posts : 3
Join date : 2009-09-06

View user profile

Back to top Go down

Re: Pump not working

Post  Mike the Boilerman on Fri Sep 18, 2009 1:38 am

Hi Dollar,

I doubt this is a pump problem. If most rads work this suggests the CH pump is working fine and that the problem is in the pipework (a blockage or valve stuck shut perhaps).

Which of the three pumps in your BM2000 is not running when you think it should be?

Cheers, Mike

Mike the Boilerman
Admin

Posts : 426
Join date : 2009-01-08

View user profile http://gledhill-repairs.forumotion.net

Back to top Go down

Re: Pump not working

Post  dollar on Fri Sep 18, 2009 9:24 am

Its the third one on the right Mike,as you look at it, at one stage it appeared to running constantly when the system was off. I have checked to see if the spindle inside turns around when the pump is switched on but it appears not.

Many thanks

dollar

Posts : 3
Join date : 2009-09-06

View user profile

Back to top Go down

Re: Pump not working

Post  Midland Boilercare on Sat Sep 19, 2009 12:58 pm

Hi Dollar

The third pump (right hand one as you look at the unit) is the hot water pump and doesn't have a bearing on central heating production.
I would be inclined to agree with Mike regarding a stuck thermostatic radiator valve or a pipework issue. It's also possible to be an issue with air in the pipework. Try turning off all of the other radiators to see if they get hot (you may hear gurgling sounds if it is air that's stopping them) and then put the others back on.

Regards
Dave Hickey
Midland Boilercare Ltd
avatar
Midland Boilercare

Posts : 142
Join date : 2009-07-15

View user profile http://www.midlandboilercare.co.uk

Back to top Go down

Re: Pump not working

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum