Systemate 2000 no central heating

Go down

Systemate 2000 no central heating

Post  Alex85 on Thu Jan 14, 2010 1:34 am

Hi,

I have had no issues with the system intil now when I noticed the house was nice and cold. Boiler (glow-worm micron 40ff) is fine, but isnt getting activated by the systemate unless I bypass the power to it. The ACB on the systemate has all 3 green leds lit and the lcd shows ON and two bars which should mean all 3 pumps are running, but only the hot water pump is running and there is only voltage to the HW pump. If you turn the knob to emergency HW and heating then all 3 pumps fire up and the heating works so they must be fine. Once you turn back to the normal position then the 3 green leds light up, but the lcd (ON) doent come back on for quite a while and the two buttons next on the screen dont function and neither does the test feature by fitting jumper 5.

As I cant do any fault finding on the ACB then all I can assume is the board is faulty? Please help as its cold

Cheers, Alex

Alex85

Posts : 2
Join date : 2010-01-14

View user profile

Back to top Go down

Re: Systemate 2000 no central heating

Post  Mike the Boilerman on Thu Jan 14, 2010 1:43 am

Hi Alex,

Yes I think it's reasonably certain you have control board failure. The only way to definitively prove it is to plug a new one in and see if the new one works properly.

Cheers, Mike

Mike the Boilerman
Admin

Posts : 426
Join date : 2009-01-08

View user profile http://gledhill-repairs.forumotion.net

Back to top Go down

Re: Systemate 2000 no central heating

Post  Alex85 on Thu Jan 14, 2010 1:49 am

Hi Mike,

Thanks for the fast reply. Its always an expensive problem! Where would be the best (read cheapest) place to get a new board?

Is it common for the boards to fail?

Cheers, Alex

Alex85

Posts : 2
Join date : 2010-01-14

View user profile

Back to top Go down

Re: Systemate 2000 no central heating

Post  Mike the Boilerman on Thu Jan 14, 2010 2:27 am

Hi Alex,

Well the cheapest place is eBay. You occasionally see them being sold by end users who bought them following a mis-diagnosis... ;-)

I suggest www.segel.co.uk - they specialise in Gledhill spares.

Yes it's common for these boards to fail. I keep several in stock all the time.

Cheers, Mike

Mike the Boilerman
Admin

Posts : 426
Join date : 2009-01-08

View user profile http://gledhill-repairs.forumotion.net

Back to top Go down

Re: Systemate 2000 no central heating

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum