Boilermate 2000 - no heating

View previous topic View next topic Go down

Boilermate 2000 - no heating

Post  JohnH on Fri Feb 19, 2010 9:03 am

Hi
We have a Boilermate 2000 with a backup switch system it is 7 years old and is used with a Gloworm Ultimate.
Recently our heating didn't come on at the preset clock time, no problems with the hot water though.
We switched to emergency heating system for a short time and then when we switched back to normal boiler operation again the CH worked ok. Now the only way we can get the CH to work is by flicking onto the emergency back up system and then back to normal operation, everytime the CH is due on.
Once we've done this it works okay until the next time.
Any suggestions to what the problem is please?

JohnH

Posts : 1
Join date : 2010-02-19

View user profile

Back to top Go down

Re: Boilermate 2000 - no heating

Post  Mike the Boilerman on Wed Mar 03, 2010 5:18 am

Hi John,

This sounds like a failure in one or other of the control boards to me. If I were on site I'd first establish that the CH pump wasn't being powered up when the controls were all set to ON, then I'd plug in a new board to see if the fault cleared. If not I'd try swapping the other board. I think you need a Gledghill specialist to visit with a stock of parts in the van!

Cheers, Mike

Mike the Boilerman
Admin

Posts : 426
Join date : 2009-01-08

View user profile http://gledhill-repairs.forumotion.net

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum