Red light on, no green light

View previous topic View next topic Go down

Red light on, no green light

Post  rebecca.austin on Sun Feb 08, 2009 5:30 am

My Pulsacoil 2000 was not producing hot water. The green light was not on and the red light was on. I was using boost when it stopped working. Both of the immersion heater thermostats were hot. I reset the manual overheat button and the green light is now on and the red light has gone off.
Will this happen again? Do I need to replace a part?


Last edited by rebecca.austin on Sun Feb 08, 2009 6:10 am; edited 1 time in total (Reason for editing : found the manual overheat button)

rebecca.austin

Posts : 1
Join date : 2009-02-08

View user profile

Back to top Go down

Re: Red light on, no green light

Post  Mike the Boilerman on Tue Feb 24, 2009 1:59 am

Hi Rebecca,

Yes it will probably happen again. It may take months or it may be immediate, or anything in between!

If it keeps doing it then the answer is to bridge out the old overheat 'stat and fit new dual function 'stats (WITH overheat protection) into the heater elements.

Cheers, Mike

Mike the Boilerman
Admin

Posts : 426
Join date : 2009-01-08

View user profile http://gledhill-repairs.forumotion.net

Back to top Go down

Check the water level as well

Post  sunny.sahdev on Wed Sep 11, 2013 6:56 am

Check the water level is correct. If the level is low, this can cause the system to overheat. If you are not 100% sure how to check it, request a free self check Pulsacoil guide via this link: Pulsacoil 2000

sunny.sahdev

Posts : 383
Join date : 2013-08-21
Age : 32
Location : Vedhas Limited, 960 Capability Green

View user profile http://www.vedhas.co.uk/vedhas-what-we-do/pulsacoil-repair/#

Back to top Go down

Re: Red light on, no green light

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum