boilermate 2000/no main lights on at all

View previous topic View next topic Go down

boilermate 2000/no main lights on at all

Post  marky123 on Tue Jul 13, 2010 11:47 am

hi there im"e an engineer currently working on the b/mate 2000 ,the fault the customer was describing sounded like the potterton suprima board clicking , on investigation it looks like the main board on the b/m 2000 has gone ,there are 3 green lights showing but nothing on the led display,is it the main a.c.b ? many thanks

marky123

Posts : 1
Join date : 2010-07-13

View user profile

Back to top Go down

Re: boilermate 2000/no main lights on at all

Post  Mike the Boilerman on Tue Jul 13, 2010 3:33 pm

marky123,

Yes almost certainly as there are green lights but display is blank. I can't imagine any fault other than ACB board failure that can cause this.

I expect the Suprima board will have failed too. They only seem to last about half an hour ;-)


Cheers, Mike


_________________
Mike Bryant AKA Mike the Boilerman, Gledhill repair specialist, webmaster of www.gledhill-repairs.co.uk & www.miketheboilerman.co.uk. For information about my Gledhill repair service or to make a booking call me on 07866 766366. (Please don't phone me for advice if you are fixing a Gledhill yourself, ask on here instead - I run this forum partly to cut down on the phone calls!)

Mike the Boilerman
Admin

Posts : 426
Join date : 2009-01-08

View user profile http://gledhill-repairs.forumotion.net

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum