PHE sensor failure

View previous topic View next topic Go down

PHE sensor failure

Post  andanotherthing on Mon Feb 09, 2009 4:45 pm

Hi,

I have been experiencing a similar problem you describe on your site where the hot water goes hot/cold/hot/cold etc. I have used the diagnostic display and have identified an intermittent PHE sensor error.

I have looked on the Gledhill site but cannot see this sensor in their parts list. Could you tell me which part to order? Should I also change the DHW sensor? Also, could you explain the procedure to change both sensors....and do you think it is worthwhile just removing and cleaning them rather than replacing them at this time?

Sorry there are a lot of questions but I would very much appreciate any advice you could give.

Regards,

Dan

andanotherthing

Posts : 1
Join date : 2009-02-09

View user profile

Back to top Go down

Re: PHE sensor failure

Post  Mike the Boilerman on Tue Feb 24, 2009 1:43 am

Hi Dan,

Cleaning them is futile!

Yes suggest replacing them both as the DHW is the one that normally fails. I'm not sure of the part number offhand but the kind peeps at

http://www.segel.co.uk/index.php?main_page=index&cPath=19

will sort you out.

Cheers!
M4

Mike the Boilerman
Admin

Posts : 426
Join date : 2009-01-08

View user profile http://gledhill-repairs.forumotion.net

Back to top Go down

Re: PHE sensor failure

Post  roromac on Wed May 06, 2009 8:00 am

Did you solve the problem?
Rob

roromac

Posts : 18
Join date : 2009-05-05

View user profile

Back to top Go down

Re: PHE sensor failure

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum