No power supply to bottom immersion

View previous topic View next topic Go down

No power supply to bottom immersion

Post  sarah1975 on Tue Dec 28, 2010 3:28 am

Hi all,
A couple of week ago we ran out of hot water and I realised the bottom immersion heater wasn't working (luckily we still have the top boost one!)

I've had the following replaced: the bottom immersion heater, relay base and wiring as this had burnt out...unfortunately the bottom immersion is still not working and it is showing on multimeter that there is no power to it at all!!

Top tank is full
Showing error code 29 on S.5 (which I can't find in the manual)
Pump and plate working fine!

Any ideas?? It's costing me a fortune! :-)

Sarah X

sarah1975

Posts : 2
Join date : 2010-12-18

View user profile

Back to top Go down

Re: No power supply to bottom immersion

Post  mike on Tue Dec 28, 2010 8:22 am

When did you check the bottom heater for supply?
Is it on E7 ?
Mike

mike

Posts : 1626
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

Re: No power supply to bottom immersion

Post  sarah1975 on Thu Dec 30, 2010 8:41 am

I've checked it at several times..after calling gledhill in the end a code 29 means the PCB controller is pooped. Apparently that means the PCB is not sending info to the bottom immersion hence why it's not working at any time! A costly repair for Christmas time! :-(

Thanks for your reply Mike X

sarah1975

Posts : 2
Join date : 2010-12-18

View user profile

Back to top Go down

Re: No power supply to bottom immersion

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum