Systemate 2000 either stays “On” or “Off” permanently – intermittent fault

Go down

Systemate 2000 either stays “On” or “Off” permanently – intermittent fault

Post  busy_bay on Wed Jan 05, 2011 5:54 pm



This is an intermittent fault which seems to have arisen since the primary pump was replaced last month (although this may just be a coincidence).

The heating will be turned on (either using the timer or advance function), but when turned off the heating will remain on. The only way to stop the heat to the radiators is to turn the Systemate 2000 completely off and then back on again (hence rebooting the whole system).

On other occasions when you go to advance the system on (or by the timer) the Systemate 2000 won’t supply the radiators with hot water. Again, if the Systemate 2000 is turned off completely and back on again, it seems to resolve the issue, supplying the radiators with hot water.

Has anyone experienced this issue or understands why this is happening?

P.S. The thermostat is always set above the current temperature when turning the system on.

Any help would be most grateful

Regards

Dave

busy_bay

Posts : 3
Join date : 2011-01-05

View user profile

Back to top Go down

Re: Systemate 2000 either stays “On” or “Off” permanently – intermittent fault

Post  mike on Thu Feb 03, 2011 10:12 am

Sounds like pcb.
This happens on the Boilermate 2000.
Checked the display on PCB ???
Mike
MGC/H2O
Norfolk

mike

Posts : 1728
Join date : 2009-10-08
Age : 65
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum