No Hot Water

View previous topic View next topic Go down

No Hot Water

Post  roukel01 on Mon Jan 17, 2011 9:38 am

We were called to a Pulsa Coil 2000 today in a rented property. No hot water. We did the usual, topped up the tank, checked power to the elements etc. Whilst the cover was off I noticed that every now and then the red LED flashed constantly for about a minute and then went back to the normal 2 flashes.
I'm not sure what this means, any help would be appreciated.

roukel01

Posts : 1
Join date : 2011-01-17

View user profile

Back to top Go down

Re: No Hot Water

Post  mike on Tue Jan 18, 2011 10:44 am

Go to Gledhill website.
Find down loads'
Pulsacoil 2000 page 23 will tell you the flashing sequence.
Was not sure by your description.
PCB, sensors or pump.
Mike
MGC/H2O

mike

Posts : 1647
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

Do just check power

Post  sunny.sahdev on Mon Sep 30, 2013 3:20 am

Check the resistance at the element and thermostat. This will tell you if it is faulty or not.

sunny.sahdev

Posts : 383
Join date : 2013-08-21
Age : 32
Location : Vedhas Limited, 960 Capability Green

View user profile http://www.vedhas.co.uk/vedhas-what-we-do/pulsacoil-repair/#

Back to top Go down

Re: No Hot Water

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum