Electramate 2000 12kw no hot water

View previous topic View next topic Go down

Electramate 2000 12kw no hot water

Post  julesmerton on Mon Sep 19, 2011 2:58 am

Hi I have recently become a landlady to a property with the above system. The tenants notified me that they have no hot water.
I called my plumber/electician who doesnt seem to know too much about this system.
He tested the voltage to the HW pump 177v and to the heating pump 240v
He unscrewed the HW pump and we saw that it was not spinning as he believed it was not getting enough voltage...
He changed the pump for a new one and no it still wasnt spinning.
We then called the technical department and they just said replace the PCB...that the pump had shorted the PCB...

I have looked online the PCB is £290 I am loathed to buy the PCB at the moment as to me the diagnosis seems a bit vague and who knows if
the original pump could still be good if fed the correct voltage..

1.can anybody shed any light on this and let me know if it does sound like the PCB ?
2.Does anybody know of a plumber/electrican who deals with these systems in the SE London area

Many thanks for any replies


julesmerton

Posts : 5
Join date : 2011-09-13

View user profile

Back to top Go down

Re: Electramate 2000 12kw no hot water

Post  MK Group Ltd on Thu Sep 22, 2011 6:45 am

Hi,

It could be either a sensor issue or PCB, are you able to give sensor reading from the existing PCB board then I will be able to determine if it is a sensor failure or PCB fault.

Kind regards

Gary

MK Group Limited
avatar
MK Group Ltd

Posts : 301
Join date : 2010-04-03

View user profile http://www.mkgroupltd.co.uk

Back to top Go down

Re: Electramate 2000 12kw no hot water

Post  julesmerton on Thu Sep 22, 2011 8:42 am

Hi Gary,
Thanks for your reply.

Hummm sensor reading? is this something a electrian/plumber would need to do?

I am pretty practical but would need more info and if need be get an electrician out.

In the meantime the wire from the pcb to the Heating pump has been connected to the new HW pump so that my tenants have running hot water as long as they keep the Heating on (radiators turned down) . This is only a temporary measure but thought it may give you a bit more info.

Jules

julesmerton

Posts : 5
Join date : 2011-09-13

View user profile

Back to top Go down

Re: Electramate 2000 12kw no hot water

Post  MK Group Ltd on Thu Sep 22, 2011 9:19 am

Hi Jules,

Do you have a manual? if not you can download one from here...


http://www.gledhill-spares.net/documents.asp

If you go to page 24 it shows you buttons SW1 & SW2 on the PCB board and then on page 32 how to read the display and go through the cycles.

Hope this helps

Kind regards

Gary

MK Group Limited
avatar
MK Group Ltd

Posts : 301
Join date : 2010-04-03

View user profile http://www.mkgroupltd.co.uk

Back to top Go down

Re: Electramate 2000 12kw no hot water

Post  julesmerton on Thu Sep 22, 2011 9:23 am

Ok thanks I will see how that works...and report back .....

much appreciate your advice

Jules

julesmerton

Posts : 5
Join date : 2011-09-13

View user profile

Back to top Go down

Re: Electramate 2000 12kw no hot water

Post  julesmerton on Fri Sep 30, 2011 6:59 am

Hi Gary...

At last a reply... I went through the sensor tests as described on the pages of the manual that you informed me of. All the points came up with a reading and none of them were showing error. From this information does this now point to replacing the PCB?

Thanks

Jules

julesmerton

Posts : 5
Join date : 2011-09-13

View user profile

Back to top Go down

Re: Electramate 2000 12kw no hot water

Post  MK Group Ltd on Fri Sep 30, 2011 7:03 am

Jules,

What are the readings? Sometimes they show readings which are inacurate.

Regards

Gary

MK Group
avatar
MK Group Ltd

Posts : 301
Join date : 2010-04-03

View user profile http://www.mkgroupltd.co.uk

Back to top Go down

Re: Electramate 2000 12kw no hot water

Post  julesmerton on Fri Sep 30, 2011 7:38 am

Hi Gary

Well following my notes with diagram I have

Store T1 60 ---sw1---64---sw1----70

PHE T2 75---sw1---35---sw1---45

DHW H76

if this makes sense...I am happy to try any further tests....

Jules

julesmerton

Posts : 5
Join date : 2011-09-13

View user profile

Back to top Go down

Re: Electramate 2000 12kw no hot water

Post  MK Group Ltd on Fri Sep 30, 2011 7:46 am

Jules,

DHW H76 means that the water would be 76degree at the tap outlet. Sounds like you have sensor issues. Also the PHE sensor seems a high reading as well, especially if the store sensors are reading 64 and 70.

It doesn't sound like pcb issue from what you have described but it does sound like the phe and dhw sensors need replacing.

Kind regards

Gary

MK Group ltd
avatar
MK Group Ltd

Posts : 301
Join date : 2010-04-03

View user profile http://www.mkgroupltd.co.uk

Back to top Go down

Re: Electramate 2000 12kw no hot water

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum