Gledhill BM 2000 ACB issue ?

View previous topic View next topic Go down

Gledhill BM 2000 ACB issue ?

Post  Flashmaster on Sun Oct 03, 2010 2:56 pm

Hello

I have a Gledhill boilermate 2000 which is not responding to the room thermostat so the heating is constantly on when set to "on" or "timer".

After removing the front

1) The green 'Power On' light is not on
2) The LED display says 'On' with just the middle horizontal LED bar (store) lit up
3) None of the green LED lights are lit up for boiler

When I press SW2 or SW1 the temp is displayed and I can confirm there are no problems with the hot water.

I am reading that this is perhaps a faulty ACB but I was hoping it wasn’t.

I have heard that you can reboot the ACB but I can not find specific instructions apparently it is to do with jumper 5.

Could someone please clarify or drop me a note with any other ideas ?

Many thanks in advance

Flashmaster

Posts : 5
Join date : 2010-10-03

View user profile

Back to top Go down

Re: Gledhill BM 2000 ACB issue ?

Post  mike on Mon Oct 18, 2010 2:31 pm

When fitting a new board is when you use the jumper 5 method.
After that should be ok.
Have you got the manual?
Down load for free at gledhill website.
Mike

mike

Posts : 1646
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

Re: Gledhill BM 2000 ACB issue ?

Post  Flashmaster on Mon Oct 25, 2010 3:03 pm

Thanks for taking time to respond.
Manage to sort it, faulty room thermostat rather than problem with the boilermate.

Thanks again

Flashmaster

Posts : 5
Join date : 2010-10-03

View user profile

Back to top Go down

Re: Gledhill BM 2000 ACB issue ?

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum