Gledhill Repairs
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Boost immersion

3 posters

Go down

Boost immersion Empty Boost immersion

Post  andym Sun Feb 01, 2009 11:32 am

I am having problems with the boost immersion. When the boost is switched on there is no feed to the immersion heater.Also the green led is not on. The off peak immersion is working ok but limited hot water. Can you help.

andym

Posts : 1
Join date : 2009-02-01

Back to top Go down

Boost immersion Empty Re: Boost immersion

Post  Mike the Boilerman Fri Feb 06, 2009 12:30 am

Hi andym,

Sounds to me as though the fuse in the On Peak supply has blown. Probably due to heater element failure. Try measuring the resistance of the element. Should be about 19 Ohms.

Green light OFF usually means the bulb has failed. Is there a red flashing light on the PCB and does the pump run? If yes then bulb failed definitely.

What do you mean by 'limited hot water' on Off Peak? Too cool? Flow too slow? Hot enough but runs out early? Swings hot and cold?

Cheers, Mike



andym wrote:I am having problems with the boost immersion. When the boost is switched on there is no feed to the immersion heater.Also the green led is not on. The off peak immersion is working ok but limited hot water. Can you help.

Mike the Boilerman
Admin

Posts : 443
Join date : 2009-01-08

https://gledhill-repairs.forumotion.net

Back to top Go down

Boost immersion Empty If it does read 19 ohms do a insulation resistance test and

Post  sunny.sahdev Wed Sep 11, 2013 6:25 am

If it does read 19 ohms do a insulation resistance test and check for signs of leaks.

sunny.sahdev

Posts : 383
Join date : 2013-08-21
Age : 35
Location : Vedhas Limited, 960 Capability Green

http://www.vedhas.co.uk/vedhas-what-we-do/pulsacoil-repair/#

Back to top Go down

Boost immersion Empty Re: Boost immersion

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum