Gledhill Repairs
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Suprima 30 & Boilermate 2 - Constant running and now lockout

Go down

Suprima 30 & Boilermate 2 - Constant running and now lockout Empty Suprima 30 & Boilermate 2 - Constant running and now lockout

Post  mcevoyd Wed Jan 04, 2012 2:15 pm

Last few days the boiler seems to have taken on a life of it's own. Boiler has been firing constantly for a few mins then shutting down. It didn't appear to be getting temp info to say it had satisfied demand. Both water and rads were running nice and hot. My first thought was that the heat store thermostat may be the culprit as the green neon light at the base of Boilermate wouldn't go out regardless of where the summer/winter temp control was set. Whilst all was obviously not well at least we had heating & hot water so I felt it was not an immediate issue. However, boiler has now red light locked out - the green neon has at last gone out so perhaps I can assume that the thermostat is ok? or would it do so because of lock out? The small header tank on top of the Boilermate is full of very hot water so much so that it is transferring heat a good way down the cold feed pipe and running out a bit down the overflow to the outside world. The ball cock float in there appears to be working ok and draws in cold water as I believe it should although not necessary at present as I said it contains plenty of water, albeit hot. So from the symtoms do you think I might need a new boiler PCB? (had a new one about 4 years ago) or just a store thermostat? Is the latter quite easy to replace? I can cope with basic DIY as I have replaced the boiler pcb and both the pump pcb's in the past. Any advise would be most welcome.

mcevoyd

Posts : 23
Join date : 2010-01-12

Back to top Go down

Suprima 30 & Boilermate 2 - Constant running and now lockout Empty Re: Suprima 30 & Boilermate 2 - Constant running and now lockout

Post  mcevoyd Wed Jan 04, 2012 2:44 pm

Ok firstly apologies for 2nd post of new topic - can't see a way to delete it. Whilst waiting for any advice from you guys I have been spending time reading loads of older posts re 'hot water in header tank'. If I have read correctly then this may be a symptom of the demise of my Boilermate! - I think probably a leaking internal coil? Likelyhood or otherwise would be helpful if anybody has the time to comment. Thanks. Assuming it is a dead un - suggestions for the future? Identical replacement or something different? Likely costs? Cheers.

mcevoyd

Posts : 23
Join date : 2010-01-12

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum