No heating, boilermate makes a croaking sound.

View previous topic View next topic Go down

No heating, boilermate makes a croaking sound.

Post  Dajonah on Sat Oct 05, 2013 1:51 pm

Hi could you please help. My boilermate 2000 central heating has stopped working. When you turn the thermostat up to call for heat it sounds like a stop/start croaking noise . The 3 lights on the board go on/off as it makes this sound. It's as if it's trying but can't. Hot water seems to be ok but I guess it could still be the stored water were using.
Thanks
Lee

Dajonah

Posts : 5
Join date : 2013-08-29

View user profile

Back to top Go down

Re: No heating, boilermate makes a croaking sound.

Post  mike on Sat Oct 05, 2013 6:54 pm

Have a read through the BM 2000 posts.
Check the normal like F & E tank.
Check middle pump ( heating)
Remember though if the unit temperature drops below 60c then heating will not work.
Mike

mike

Posts : 1646
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

Re: No heating, boilermate makes a croaking sound.

Post  Mario.S on Sun Oct 06, 2013 3:00 am

Dajonah wrote:Hi could you please help. My boilermate 2000 central heating has stopped working. When you turn the thermostat up to call for heat it sounds like a stop/start croaking noise . The 3 lights on the board go on/off as it makes this sound. It's as if it's trying but can't. Hot water seems to be ok but I guess it could still be the stored water were using.
Thanks
Lee
quick question> all 3 lights or only the top of the 3?
If only the top, means probably , the store temperature is just on the 55c / 60c ( depending on pcb software version) and your gas boiler is not fast enough to compensate the heat loss. Switch the heating off on the thermostat on the wall and give the boiler bit more time to heat the BM2000.
If all 3 led go off, two things, check the power supply to the boiler on terminal 1 on the pcb and on terminal 1 on the terminal block. If there is power and it's not going off like your pcb led 's, it is the pcb fault, if the power goes off like the pcb, check your external switch on the wall / kitchen, there is a loose connection or faulty wall switch.
Hope this helps
kind regards Mario at Mario's Boiler Service

Mario.S

Posts : 224
Join date : 2011-12-10
Location : Fareham / Hampshire

View user profile http://www.marios-boiler-service.co.uk/

Back to top Go down

Re: No heating, boilermate makes a croaking sound.

Post  Dajonah on Sun Oct 06, 2013 4:10 am

Hi, I've pressed sw2 and it said 70c but it wouldn't come out off that just stuck on 70c so I switched the unit off and on and now I have no display just the 3 green lights lit.
Answer to your last question Mario is HL1 HL2 HL3 were fully lit but going on/off like an indicator does at the same time as the croaking noise when it was try to heat up the radiators. I moved the lever on the pump from 3 to 1 and back and this seemed to stop the noise momentarily.
Looks like it's not working at all now :-(
Thanks for any advice.
Lee

Dajonah

Posts : 5
Join date : 2013-08-29

View user profile

Back to top Go down

Re: No heating, boilermate makes a croaking sound.

Post  mike on Sun Oct 06, 2013 4:19 am

No display.
Looks like Main board gone ( ACB)
Switch off and leave.
Switch on, may reboot.
Check all connections etc.
Mike

mike

Posts : 1646
Join date : 2009-10-08
Age : 64
Location : Norwich

View user profile http://www.mgch20.co.uk

Back to top Go down

Re: No heating, boilermate makes a croaking sound.

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum